How To: Få igång ditt Atheros AR242x WLAN-kort i Ubuntu 8.10 Intrepid Ibex

closeDetta inlägg skrevs för 10 år 5 månader 16 dagar sedan, och om det är av karaktären åsikt, så reserverar jag mig för att jag mycket sannolikt kan ha ändrat den sedan dess. Är det en guide så kan det också vara så att det inte längre är applicerbart eller fungerar. Dock vill jag inte ta bort, eller orkar sortera, gamla inlägg och därför är det kvar.

Då jag är fadder i det svenska Ubuntu-forumet så får jag en hel del frågor. Idag fick jag en om hur man  får igång Atheros AR242x i Ubuntu Intrepid. Guiden var tänkt att vara en guide med steg för steg, men jag satt istället ihop ett skript som gör allt åt dig. Du behöver bara göra några småsteg.

Alla kommandon är hämtade ifrån denna HowTo: http://madberry.org/2008/11/how-to-get-atheros-ar242x-to-work-on-810-intrepid-ibex/

Nåväl – nu kör vi igång!

1.Börja med att ladda ned mitt skript härifrån. Gör sedan skriptet körbart.
Terminal: chmod +x (vartfilenligger)atheros-ar242x-v1.run
Grafiskt: Högerklicka på filen > Gå till fliken rättigheter och där kan man klicka i ”tillåt körning av filen som ett program”.

2. För att sedan köra det så gör du såhär:
Terminal: ./atheros-ar242x-v1.run
Grafiskt: Dubbelklicka på filen och välj; ”Kör i Terminal”.

Följ nu instruktionerna och så fixar sig resten. Du kan öppna filen i ett textredigare-program så får du se exakt vad skriptet gör.

När du sedan startat om datorn och det fortfarande inte fungerar så beror det på att modulen ath5k inte är laddad. Kör detta kommando så kommer det automatiskt laddas vid varje uppstart:
$ echo ath5k | sudo tee -a /etc/modules

6 svar på ”How To: Få igång ditt Atheros AR242x WLAN-kort i Ubuntu 8.10 Intrepid Ibex”

  1. Hejsan. Tack för din fina guide.
    Fick den att funka efter vissa modifieringar.
    Den ville inte installera compat-wireless så fick göra det manuellt =)
    Men fick i allafall igång det , så nu funkar det kalas :D

    1. Hej, Vad kul att höra! :D

      Tycker du att det är något som jag borde lägga till i skriptet så att man slipper gra det manuellet, eller borde det förbli som det är?

      Tack.

      1. Jadu , jag vet inte vad det är som gör att det inte går..

        Kollade igenom scriptet , och den kör ju aldrig någon configure?
        Kan det vara det kanske?

        Jag fick bara upp rutan om att starta om när jag körde scriptet , lägger man till det så kanske det kan bli helt automatiskt? För det är väl meningen.

        1. När du kommer så långt som att du blir ombedd att starta om så är resten klart. Anledningen till att ./configure inte är med är precis so du säger, att det itne behövs. Make filen finns redan.

          Testa att köra skriptet i en terminal istället; ./skript.run
          Då ser du även felmeddelanden. Kanske ska ta och lägga till så att det sparas en logg av allting när man kör skriptet?

           

  2. Aha , okey.. Jo men rutan kom ju upp.. Men det hade inte installeras.
    Och jag kör alltid terminal. Så såg ju vad den gjorde. Men hoppade över det av någon anledning?

    1. Låter verkligen jätte lustigt, för mig funkar det prima. Du kan väl köra;
      $ ./skript.run > digivox.log

      Så kan du sedan skicka den filen till mig (använd kontaktoforumläret så svarar jag där så du får min mail) så jag kan läsa vad problemet kan vara.

Kommentarer inaktiverade.